by: (5 pts)
My gaggia titanium machine was stuck on rinsing and the brew unit was stuck in the machine. I followed the instructions on the video on how to remove the brew unit and everything worked fine up to the point where I have to reset the gear. I'm holding the trigger down with paper as shown in the video and the machine says it's rinsing, sounds like it does, but no water comes out of nowhere! I tried opening the wand valve.Water comes out of the wand and it displays "Rinsing cycle Close knob". I tried removing the paper it displays "Rinsing cycle Brew unit missing" and a again no water comes out. I tried removing the water tank in hopes I would get it to display ventilate, but nothing. I tried living it on and though it says rinsing, it's not. Any suggestions?
Answered by Maggie
E239c350690d12a858e492bc395c19b8 Robin, Unfortunately, this particular issue means that the machine would need to come in for repair. Please call technical support at 1-888-411-5282, option 3. so that we can assist you. 11-01-13 04:30PM
Was this answer helpful?

Answer This Question

Please Sign In to answer this question