by: (5 pts)
Recently, my Gaggia Platinum Vision seems to have given up the ghost. The machine will not make coffee, or even advance to the main menu. Upon cycling the power, I can hear a couple of clicking / clunking noises (which are louder if I turn the steam knob on), then the message "dispensing failed" flashes on the screen, followed by the wrench and "restart to solve problem" message. Restarting does nothing but repeat that cycle. Also, I get this message whether I have the brew group inserted, or not (trying to troubleshoot). I have maintained the machine per instructions, have lubricated the brew group and checked for free movement, cleaned the grinder, brew head, and descaled within a couple weeks. The machine seemed to be working fine until this problem occurred. Any chance this is user serviceable? I love fixing things myself.
Answered by Sanfam
0d219748120cdc26ee5d5603498f2d11 Kevin, Thank you for your message. Unfortunately, this isn't something with a terribly straightforward solution. The repeated "clicking/clunking" sound typically indicates that the water flow actuators are not fully triggering, suggesting that problem could be electrical, either stemming from a bad CPU or a bad power board. In any case, this is something that could conceivably be undertaken, wouldn't be easy and could easily become expensive and/or prove futile. While I'm often the first to suggest opening things up and poking around, this is a case where a trained technician is best able to sort things out. Given the problem, I would advise sending this machine in for service at this time. 11-01-13 05:03PM
Was this answer helpful?
0
0

Answer This Question

Please Sign In to answer this question